Let’s configure R0 and R1 for dual-stacking and R2 for IPv6 operations only.

R0#conf t
R0(config)#ipv6 unicast-routing
R0(config)#interface FastEthernet0/0
R0(config-if)#ip address 192.168.0.1 255.255.255.0
R0(config-if)#ipv6 address 2001:db8:1:1::/64 eui-64
R0(config-if)#no shutdown
R0(config-if)#interface FastEthernet0/1
R0(config-if)#ipv6 address 2001:db8:1:2::/64 eui-64
R0(config-if)#no shutdown

R1#conf t
R1(config)#ipv6 unicast-routing
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 192.168.0.2 255.255.255.0
R1(config-if)#ipv6 address 2001:db8:1:1::/64 eui-64
R1(config-if)#no shutdown

R2#conf t
R2(config)#ipv6 unicast-routing
R2(config)#interface FastEthernet0/0
R2(config-if)#ipv6 address 2001:db8:1:2::/64 eui-64
R2(config-if)#no shutdown

For a router to be able to forward IPv6 packets, you must first use the ipv6 unicast-routing global configuration command.

As you can see, we used static IPv6 addresses using EUI-64 interface ID. You can check the IP address of the router with show ipv6 interface interface.

R0#show ipv6 interface FastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::C609:EFF:FED4:0
No Virtual link-local address(es):
Global unicast address(es):
2001:DB8:1:1:C609:EFF:FED4:0, subnet is 2001:DB8:1:1::/64

[EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FFD4:0

The link-local address is the address used by the router to refer to that particular physical link. The router is using this address for automatic address configuration, neighbor discovery, and router discovery. As we already told you in a previous lesson, this address begins with “FE” and has the third hexadecimal digit between “8” and “B”.

Next, we have the IPv6 address of the router, 2001:DB8:1:1:C609:EFF:FED4:0 and subnet of which is part of, 2001:DB8:1:1::/64. You may note that when we configured the address, we only added 2001:DB8:1:1::/64 and we used EUI-64. EUI-64 used the Layer 2 address of the router, in our case the MAC address, to generate the interface ID (host) portion of the IPv6 address, which is C609:EFF:FED4:0.

To check the connectivity of the routers, link in IPv4, use the ping command. We will try to ping R0 from R1. We already know the IPv6 address of R0.

R1#ping 2001:DB8:1:1:C609:EFF:FED4:0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:1:1:C609:EFF:FED4:0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/85/132 ms

If you need to check the IPv6 configuration of all interfaces on a router, use the show ipv6 interface brief.

R0#show ipv6 interface brief
FastEthernet0/0 [up/up]FE80::C609:EFF:FED4:0
2001:DB8:1:1:C609:EFF:FED4:0
FastEthernet0/1 [up/up]FE80::C609:EFF:FED4:1
2001:DB8:1:2:C609:EFF:FED4:1

As you can see, on this router we have only two interfaces enabled for IPv6. The first address is the link-local address and the second address is the unicast address.

We hope you enjoyed this lesson. We are proud to provide not only top-notch certification articles but also real-life examples. Although IPv6 is covered only briefly in the CCNA exam, you must have a good understanding of these concepts and you must be able to configure a basic IPv6-enabled network. In our next lesson, we will show you how to enable RIPng in your network, as required by the Cisco CCNA exam.