Cisco CCNA – Configuring EIGRP

Cisco CCNA – Configuring EIGRP

First, let’s configure the IP addresses on the interfaces of the routers.

R0(config)#int Fa0/0
R0(config-if)#ip addr 172.16.1.1 255.255.255.0
R0(config-if)#no shutdown
R0(config-if)#int Fa0/1
R0(config-if)#ip addr 192.168.1.1 255.255.255.0
R0(config-if)#no shutdown
R1(config)#int Fa0/0
R1(config-if)#ip addr 172.16.1.2 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#int Fa0/1
R1(config-if)#ip addr 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown
R2(config)#int Fa0/0
R2(config-if)#ip addr 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R3(config)#int Fa0/0
R3(config-if)#ip addr 192.168.2.2 255.255.255.0
R3(config-if)#no shutdown

Now, let’s enable EIGRP and specify what networks to advertise to our neighbors. We will use EIGRP autonomous system (AS) 1.

R0(config)#router eigrp 1
R0(config-router)#network 172.16.1.0 0.0.0.255
R0(config-router)#network 192.168.1.0

Optionally, in EIGRP, you can specify the wildcard bits when you chose to advertise a network. By default, when using the network command and a classful network address such as 172.16.1.0, all interfaces will be enabled for EIGRP. Although this is not our case, if you don’t want to enable all of them, you must specify the wildcard mask. To calculate the wildcard mask, you must substract the subnet mask from 255.255.255.255. For example, the wildcard mask for 255.255.255.252 is 255.255.255.255 – 255.255.255.252 = 0.0.0.3.

Let’s continue to configure the other routers now.

R1(config-router)#router eigrp 1
R1(config-router)#network 172.16.1.0
R1(config-router)#
*Mar  1 00:14:27.267: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.1.1 (FastEthernet0/0) is up: new adjacency
R1(config-router)#network 192.168.2.0
R2(config)#router eigrp 1
R2(config-router)#network 192.168.1.0
R2(config-router)#
*Mar  1 00:16:17.475: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.1.1 (FastEthernet0/0) is up: new adjacency
R3(config)#router eigrp 1
R3(config-router)#network 192.168.2.0
R3(config-router)#
*Mar  1 00:17:02.279: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.2.1 (FastEthernet0/0) is up: new adjacency
Now, let’s check the routing table.
R3#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route
Gateway of last resort is not set

D    172.16.0.0/16

[90/307200] via 192.168.2.1, 00:00:35, FastEthernet0/0
D    192.168.1.0/24 [90/332800] via 192.168.2.1, 00:00:35, FastEthernet0/0
C    192.168.2.0/24 is directly connected, FastEthernet0/0

As you can see, the routing table is already populated with the routes. Let’s check the neighbors.
R0#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
1   192.168.1.2             Fa0/1             10 00:04:27    8   200  0  4
0   172.16.1.2              Fa0/0             13 00:06:17    6   300  0  9

The fields of this command show you the following:

  • H column – lists the neighbors in the order they were learned.
  • Address – the IP address of the neighbor.
  • Interface – the local interface on which the Hello packet was received.
  • Hold – the current hold time. Every time a Hello packet is received, this value is reset to the maximum hold time for that interface and then counts down to zero. If zero is reached, the neighbor is considered down.
  • Uptime – amount of time since the neighbor was added to the neighbor table
  • SRTT (Smooth Round Trip Timer) and RT0 (Retransmit Interval ) – used by RTP to manage reliable EIGRP packets.
  • Queue Count – should always be zero, else EIGRP packets are waiting to be sent.
  • Sequence Number – used to track updates, queries and reply packets.

As with the other routing protocols, you can use the show ip protocols command to check detailed information about your routing protocols.
R0#show ip protocols
Routing Protocol is “eigrp 1
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 1
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is in effect
Automatic address summarization:
192.168.1.0/24 for FastEthernet0/0
172.16.0.0/16 for FastEthernet0/1
Summarizing with metric 281600
Maximum path: 4
Routing for Networks:
172.16.1.0/24
192.168.1.0
Routing Information Sources:
Gateway         Distance      Last Update
(this router)         90      00:16:06
172.16.1.2            90      00:11:56
Distance: internal 90 external 170

When automatic summarization is enabled or at least one subnet was learned via EIGRP, EIGRP includes a summary route. Null0 is the interface used for summary routes. This is a “virtual” interface used only for advertising purposes.

R0#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:37:40, Null0
C       172.16.1.0/24 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/1
D    192.168.2.0/24 [90/307200] via 172.16.1.2, 00:33:30, FastEthernet0/0

To calculate the preferred path on a network, EIGRP uses the following values in its composite metric:

  • Bandwidth
  • Delay
  • Reliability
  • Load

The default composite formula is: metric = [K1 * bandwidth + K3*delay]
By default, K1 and K3 are set to 1, and K2, K4 and K5 are set to 0. These values can be changed with metric weights tos k1 k2 k3 k4 k5 EIGRP router configuration command.

To find out the values used by EIGRP for the bandwidth, delay, reliability and load use the show interface interface interface-number command.
R0#show interface Fa0/0
FastEthernet0/0 is up, line protocol is up
Hardware is Gt96k FE, address is c400.039f.0000 (bia c400.039f.0000)
Internet address is 172.16.1.1/24
MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Half-duplex, 10Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00

When you use Serial interfaces, the default bandwidth value may not match your real bandwidth which may cause EIGRP to not work properly. In this case, you have to manually configure the bandwidth value for your interface. Although, this is not our case, because we use FastEthernet interface, we will demonstrate you how to accomplish this, with the bandwidth kilobits interface configuration command.

R0(config)#interface Serial 0/0/0
R0(config-if)#bandwidth 1024

EIGRP is one of the most used Interior Gateway Protocols (IGP) used these days. In your preparation for your CCNA exam, you must know the basics of EIGRP and we hope you found this article useful for achieving the basic knowledge required for the CCNA certification exam. Remember that practice is best way to prepare for the CCNA exam, and we can provide you with many training resources, including labs prepared specially for the exam on which you can setup your own EIGRP enabled topologies.