Configuring a Frame Relay with OSPF 

These labs are not as good as the labs in our full blown CCNA Lab Workbook.  The labs in our full blown CCNA lab workbook include theory as we step you through each lab, detailed information on why you are entering each command and review questions and answers at the end of the labs.  So these labs are ok for free…but we offer a much better product consisting of 60 labs covering 400 pages of CCNA material to help you pass your CCNA Certification Exam in the workbook at this link CCNA Lab Workbook!

 

frame-relay-ospf

Objective:

In this lab we’ll configure a frame relay switch running OSPF.

Hardware Requirements:

· One Cisco router with two serial ports

· One Cisco router with one Ethernet port and two serial ports

· Two Cisco routers with one Ethernet port and one serial port

· Cisco IOS 12.0 or higher

· A PC running a terminal emulation program

· Three back to back DTE/DCE serial cable s

· Cisco console kit

Configuring Frame Relay

Router#Config t

Router(config)#hostname FR

FR(config)#enable password cisco

FR(config)#line vty 0 4

FR(config-line)# password cisco

FR(config-line)# login

FR(config)#frame-relay switching

FR(config)#int s0

FR(config-if)# no ip address

FR(config-if)# encapsulation frame-relay

FR(config-if)# clockrate 64000

FR(config-if)# frame-relay lmi-type ansi

FR(config-if)# frame-relay intf-type dce

FR(config-if)# frame-relay route 100 interface Serial0/1 200

FR(config-if)# no shut

FR(config)# int s1

FR(config-if)# no ip address

FR(config-if)# encapsulation frame-relay

FR(config-if)# clockrate 64000

FR(config-if)# frame-relay lmi-type ansi

FR(config-if)# frame-relay intf-type dce

FR(config-if)# frame-relay route 200 interface Serial0/0 100

FR(config-if)# no shut

FR(config)#end

FR# wr

 

Router 1

Router#conf t

Router(config)#hostname R1

R1(config)#enable password cisco

R1(config)#line vty 0 4

R1(config-line)# password cisco

R1(config-line)# login

R1(config-line)#int Loopback0

R1(config-if)# ip address 1.1.1.1 255.255.255.255

R1(config-if)# no shut

R1(config)#int Loopback1

R1(config-if)# ip address 1.1.1.2 255.255.255.255

R1(config-if)# no shut

R1(config)#int e0

R1(config-if)# ip address 192.1.1.1 255.255.255.0

R1(config-if)# no keepalive

R1(config-if)# no shut

R1(config)#int s0

R1(config-if)# ip address 10.1.1.1 255.255.255.0

R1(config-if)# encapsulation frame-relay

R1(config-if)# frame-relay map ip 10.1.1.1 100 broadcast

R1(config-if)# frame-relay map ip 10.1.1.2 100 broadcast

R1(config-if)# frame-relay lmi-type ansi

R1(config-if)# no shut

R1(config)#router ospf 100

R1(config-router)# network 1.1.1.2 0.0.0.0 area 0

R1(config-router)# network 10.1.1.0 0.0.0.255 area 0

R1(config-router)# network 192.1.1.0 0.0.0.255 area 0

R1(config-router)# neighbor 10.1.1.2

R1(config-router)# end

R1# wr

Router 2

Router#conf t

Router(config)#hostname R2

R2(config)#enable password cisco

R2(config)#line vty 0 4

R2(config-line)# password cisco

R2(config-line)# login

R2(config-line)#int Loopback0

R2(config-if)# ip address 2.2.2.1 255.255.255.255

R2(config-if)# no shut

R2(config)#int Loopback1

R2(config-if)# ip address 2.2.2.2 255.255.255.255

R2(config-if)# no shut

R2(config)#int e0

R2(config-if)# ip address 193.1.1.2 255.255.255.0

R2(config-if)# no keepalive

R2(config-if)# no shut

R2(config)#int s0

R2(config-if)# ip address 10.1.1.2 255.255.255.0

R2(config-if)# encapsulation frame-relay

R2(config-if)# ip ospf priority 0

R2(config-if)# frame-relay map ip 10.1.1.1 200 broadcast

R2(config-if)# frame-relay map ip 10.1.1.2 200 broadcast

R2(config-if)# frame-relay lmi-type ansi

R2(config-if)# no shut

R2(config)#int s1

R2(config-if)# ip address 11.1.1.2 255.255.255.0

R2(config-if)# clockrate 64000

R2(config-if)# no shut

R2(config)#router ospf 100

R2(config-router)# network 2.2.2.1 0.0.0.0 area 1

R2(config-router)# network 2.2.2.2 0.0.0.0 area 0

R2(config-router)# network 10.1.1.0 0.0.0.255 area 0

R2(config-router)# network 11.1.1.0 0.0.0.255 area 1

R2(config-router)# network 193.1.1.0 0.0.0.255 area 1

R2(config-router)# end

R2#wr

Router 3

Router#conf t

Router(config)#hostname R3

R3(config)#enable password cisco

R3(config)#line vty 0 4

R3(config-line)# password cisco

R3(config-line)# login

R3(config-line)#int Loopback0

R3(config-if)# ip address 3.3.3.1 255.255.255.255

R3(config-if)# no shut

R3(config)#interface Loopback1

R3(config-if)# ip address 3.3.3.2 255.255.255.255

R3(config-if)# no shut

R3(config)#int e0

R3(config-if)# ip address 194.1.1.3 255.255.255.0

R3(config-if)# no keepalive 

R3(config-if)# no shut

R3(config)#int s0

R3(config-if)# ip address 11.1.1.3 255.255.255.0

R3(config-if)# ip ospf priority 0

R3(config-if)# no shut

R3(config)#router ospf 100

R3(config-router)# network 3.3.3.3 0.0.0.0 area 1

R3(config-router)# network 194.1.1.0 0.0.0.255 area 1

R3(config-router)# network 11.1.1.0 0.0.0.255 area 1

R3(config-router)# end

R3# Wr

Testing Frame Relay

FR#show frame route

02:57:09: %SYS-5-CONFIG_I: Configured from console by console

Input Intf Input Dlci Output Intf Output Dlci

Status

Serial0/0 100 Serial0/1 200 active

Serial0/1 200 Serial0/0 100 active

 

Router 1

R1#sho ip route

(Output omitted)

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 2 subnets

C 1.1.1.1 is directly connected, Loopback0

C 1.1.1.2 is directly connected, Loopback1

2.0.0.0/32 is subnetted, 2 subnets

O 2.2.2.2

[110/65] via 10.1.1.2, 00:02:05, Serial0

O IA 2.2.2.1 [110/65] via 10.1.1.2, 00:01:14, Serial0

10.0.0.0/24 is subnetted, 1 subnets

C 10.1.1.0 is directly connected, Serial0

11.0.0.0/24 is subnetted, 1 subnets

O IA 11.1.1.0 [110/128] via 10.1.1.2, 00:01:14, Serial0

O IA 193.1.1.0/24 [110/74] via 10.1.1.2, 00:01:14, Serial0

C 192.1.1.0/24 is directly connected, Ethernet0

O IA 194.1.1.0/24 [110/138] via 10.1.1.2, 00:01:14, Serial0

 

R1#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface

2.2.2.2 0 FULL/DROTHER 00:01:52 10.1.1.2 Serial0

 

R1#ping 194.1.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 194.1.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 92/102/120 ms

 

R1#ping 11.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 11.1.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 64/68/84 ms

R1#

 

Router 2

R2#sh ip route

(Output omitted)

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets

O 1.1.1.2 [110/65] via 10.1.1.1, 00:03:05, Serial0

2.0.0.0/32 is subnetted, 2 subnets

C 2.2.2.2 is directly connected, Loopback1

C 2.2.2.1 is directly connected, Loopback0

10.0.0.0/24 is subnetted, 1 subnets

C 10.1.1.0 is directly connected, Serial0

11.0.0.0/24 is subnetted, 1 subnets

C 11.1.1.0 is directly connected, Serial1

C 193.1.1.0/24 is directly connected, Ethernet0

O 192.1.1.0/24 [110/74] via 10.1.1.1, 00:03:05, Serial0

O 194.1.1.0/24 [110/74] via 11.1.1.3, 00:02:15, Serial1

 

R2#ping 1.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/64 ms

 

R2#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/60 ms

 

R2#sho ip ospf nei

Neighbor ID Pri State Dead Time Address Interface

1.1.1.2 1 FULL/DR 00:01:53 10.1.1.1 Serial0

3.3.3.2 0 FULL/ – 00:00:31 11.1.1.3 Serial1

 

Router 3

R3#sho ip route

(Output omitted)

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets

O IA 1.1.1.2 [110/129] via 11.1.1.2, 00:02:49, Serial0

2.0.0.0/32 is subnetted, 2 subnets

O IA 2.2.2.2 [110/65] via 11.1.1.2, 00:02:49, Serial0

O 2.2.2.1 [110/65] via 11.1.1.2, 00:02:49, Serial0

3.0.0.0/32 is subnetted, 2 subnets

C 3.3.3.2 is directly connected, Loopback1

C 3.3.3.1 is directly connected, Loopback0

10.0.0.0/24 is subnetted, 1 subnets

O IA 10.1.1.0 [110/128] via 11.1.1.2, 00:02:49, Serial0

11.0.0.0/24 is subnetted, 1 subnets

C 11.1.1.0 is directly connected, Serial0

O IA 192.1.1.0/24 [110/138] via 11.1.1.2, 00:02:49, Serial0

O 193.1.1.0/24 [110/74] via 11.1.1.2, 00:02:49, Serial0

C 194.1.1.0/24 is directly connected, Ethernet0

 

R3#ping 1.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echoes to 1.1.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 84/86/88 ms

 

R3#ping 3.3.3.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echoes to 3.3.3.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

R3#ping 192.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echoes to 192.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 84/85/88 ms