Configuring a Frame Relay Switch Lab A

These labs are not as good as the labs in our full blown CCNA Lab Workbook.  The labs in our full blown CCNA lab workbook include theory as we step you through each lab, detailed information on why you are entering each command and review questions and answers at the end of the labs.  So these labs are ok for free…but we offer a much better product consisting of 60 labs covering 400 pages of CCNA material to help you pass your CCNA Certification Exam in the workbook at this link CCNA Lab Workbook!

 

frame-relay-1

Objective

In this lab, you will configure a frame relay switch and network.  Once your configuration is complete, you will use debugging and show commands to view your configuration.

Hardware Requirements

• One router with two serial ports

• Two routers with one serial port and one Ethernet port

• Three back to back DTE/DCE serial cables

• IOS version 12.x or later

• A PC running a terminal emulation program

• Cisco console kit

 

Setup

• Configure the cabling as shown in the network diagram

• If the routers have a startup-config, erase it and perform a reload of the routers.

 

RouterA

Router>en

Router#config t

Router(config)#hostname RouterA

RouterA(config)#enable password cisco

RouterA(config)#int s0

RouterA(config-if)#ip address 192.168.1.1 255.255.255.0

RouterA(config-if)#no shut

RouterA(config-if)#encapsulation frame-relay

RouterA(config-if)#frame-relay lmi-type ansi

RouterA(config-if)#router rip

RouterA(config-router)#network 192.168.1.0

RouterA(config-router)#no ip classless

RouterA(config)#line vty 0 4

RouterA(config-line)#login

RouterA(config-line)#password cisco

RouterB

Router>en

Router#config t

Router(config)#hostname RouterB

RouterA(config)#enable password cisco

RouterA(config)#int s0

RouterA(config-if)#ip address 192.168.1.2 255.255.255.0

RouterA(config-if)#no shut

RouterA(config-if)#encap

RouterA(config-if)#encapsulation <type -> frame

RouterA(config-if)#encapsulation frame-relay

RouterA(config-if)#frame-relay lmi-type ansi

RouterA(config-if)#router rip

RouterA(config-router)#network 192.168.1.0

RouterA(config-router)#

RouterA(config-router)#no ip classless

RouterA(config)#line vty 0 4

RouterA(config-line)#login

RouterA(config-line)#password cisco

FrameSwitch (serial0)

Router>en

Router#config t

router(config)#hostname FrameSwitch

FrameSwitch(config)#

FrameSwitch(config)#frame-relay switching

FrameSwitch(config)#

FrameSwitch(config)#int s0

FrameSwitch(config-if)#no ip address

FrameSwitch(config-if)#no shut

FrameSwitch(config-if)#encapsulation frame-relay

FrameSwitch(config-if)#clockrate 64000

FrameSwitch(config-if)#frame-relay lmi-type ansi

FrameSwitch(config-if)#frame-relay intf-type dce

FrameSwitch(config-if)#frame-relay route 100 interface serial1 101

FrameSwitch(config)#int s1

FrameSwitch(config-if)#no ip address

FrameSwitch(config-if)#no shut

FrameSwitch(config-if)#encapsulation frame-relay

FrameSwitch(config-if)#clockrate 64000

FrameSwitch(config-if)#frame-relay lmi-type ansi

FrameSwitch(config-if)#frame-relay intf-type dce

FrameSwitch(config-if)#frame-relay route 101 interface serial0 100

 

FYI: The PVCs (Permanent Virtual Circuits) are defined using the frame-relay route command.  When we configure the router Frameswitch with the command frame-relay route 100 interface serial1 101 on serial0, we’re saying any package identified with DLCI 100, destined for DLCI 101, switch over to serial1 and when we configure the serial1 with the frame-relay route command, frame-relay route 101 interface serial0 100, that creates the PVC.

 

Frame Relay Monitoring

Router# show interface or show interface serial are the most common command s which show a wide variety of information including showing you the DLCI used for LMI. When monitoring Frame Relay information on the router, a number of items are typically monitored including DLCI and LMI.

 

Router# debug frame-relay LMI command that you would use to monitor LMI information

 

Frame Relay Troubleshooting Commands

If a Frame-Relay DLCI attains a state other than “active” meaning inactive or deleted, you can check the Frame-Relay configuration to make sure its configuration matches the configuration of the router acting as the Frame-Relay DTE device.

 

Router# show frame-relay pvc – can be used to verify that the Frame-Relay PVCs are active and operational

 

Router# show frame-relay route – can be used to get a listing of the status of all the PVC’s

 

Router# show frame-relay map – can be used to verify that inverse ARP has successfully mapped remote network layer addresses to the appropriate DLCI.