Configuring IGRP & Verifying Connectivity Lab B

These labs are not as good as the labs in our full blown CCNA Lab Workbook.  The labs in our full blown CCNA lab workbook include theory as we step you through each lab, detailed information on why you are entering each command and review questions and answers at the end of the labs.  So these labs are ok for free…but we offer a much better product consisting of 60 labs covering 400 pages of CCNA material to help you pass your CCNA Certification Exam in the workbook at this link CCNA Lab Workbook!

 

igrp

Objective: In this lab, you will configure IGRP on all three routers. This will allow your routers to route packets so that all routers and all hosts will be able to reach (ping) each other. Once your configuration is complete, you will use basic techniques to test your network’s connectivity.

Hardware Requirements

• One router with two serial ports and one Ethernet port

• Two routers with one serial port and one Ethernet port

• Two back to back DTE/DCE serial cables

• IOS version 12.x or later

• A PC running a terminal emulation program

• Cisco console kit

 

Setup

• Configure the cabling as shown in the network diagram

• If the routers have a startup-config, erase it and perform a reload of the routers.

 

FYI: The routing update interval must be the same value on neighboring routers.

RouterA

Router>en

Router#config t

Router(config)#hostname RouterA

RouterA(config)#int loopback0 (Defines a virtual interface that will be used as test point)

RouterA(config-if)#ip address 10.1.1.1 255.255.255.0

RouterA(config-if)#no shut

RouterA(config-if)#int e0

RouterA(config-if)#ip address 148.1.1.1 255.255.255.0

RouterA(config-if)#no shut

RouterA(config-if)#no keepalive (Disabling the keepalives on an interface, allows the interface to stay up when it is not attached to hub, a switch or another interface)

RouterA(config-if)#int s0

RouterA(config-if)#ip address 192.1.1.1 255.255.255.0

RouterA(config-if)#no shut

RouterA(config-if)#router igrp 100(Enables the IGRP routing process on the router using the AS number 100)

RouterA(config-router)#network 10.0.0.0 (Specifies what interfaces will receive and send IGRP routing updates and it specifies what networks will be advertised)

RouterA(config-router)#network 148.1.0.0

RouterA(config-router)#network 192.1.1.0

RouterA(config-router)#no ip classless

RouterB

Router>en

Router#config t

Router(config)#hostname RouterB

RouterB(config-if)#int e0

RouterB(config-if)#ip address 150.1.1.1 255.255.255.0

RouterB(config-if)#no shut

RouterB(config-if)#no keepalive (Disabling the keepalives on an interface, allows the interface to stay up when it is not attached to hub, a switch or another interface)

RouterB(config-if)#int s0

RouterB(config-if)#ip address 192.1.1.2 255.255.255.0

RouterB(config-if)#no fair-queue

RouterB(config-if)#clock rate 500000

RouterB(config-if)#no shut

RouterB(config-if)#int s1

RouterB(config-if)#ip address 193.1.1.2 255.255.255.0

RouterB(config-if)#clock rate 500000

RouterB(config-if)#no shut

RouterB(config-if)#router igrp 100(Enables the IGRP routing process on the router using the AS number 100)

RouterB(config-router)#network 192.1.1.0 (Specifies what interfaces will receive and send IGRP routing updates. It also specifies what networks will be advertised)

RouterB(config-router)#network 193.1.1.0

RouterB(config-router)#no ip classless

RouterC

Router>en

Router#config t

Router(config)#hostname RouterC

RouterC(config-if)#int e0

RouterC(config-if)#ip address 152.1.1.1 255.255.255.0

RouterC(config-if)#no shut

RouterC(config-if)#no keepalive (Disables the keepalives on theEthernet interface, allows the interface to stay up when it is not attached to hub, a switch or another interface)

RouterC(config-if)#int s0

RouterC(config-if)#ip address 193.1.1.1 255.255.255.0

RouterC(config-if)#no shut

RouterC(config-if)#Router igrp 100(Enables the IGRP routing process on the router using the AS number 100)

RouterC(config-router)#network 152.1.0.0 (Specifies what interfaces will receive and send IGRP routing updates. It also specifies what networks will be advertised)

RouterC(config-router)#network 193.1.1.0

RouterC(config-router)#no ip classless

Monitoring and Troubleshooting

IGRP is a Cisco proprietary protocol and was designed to overcome the 15 hop limitation of RIP.  IGRP defaults to100 hop and can have a maximum hop count of 255.

 

Show the IP routing table on RouterA with the show ip route command.

 

RouterA#show ip route

Find the routing table entries received using IGRP.

 

From RouterA, watch the routing packets being passed using the debug ip igrp transactions command. Notice that on interface serial 0, the router does not advertise the networks it learned from RouterB (152.1.1.0 and 193.1.1.0) but on all other interfaces, those networks are advertised. This is how split horizons works – when split horizons is enabled, the router will never advertise a route back in the direction from which it was learned.

RouterA#debug ip igrp events

IGRP protocol debugging is on

Disable split horizons on RouterA using the interface configuration command, no ip splithorizon.

RouterA(config)#int s0

RouterA(config-if)#no ip split-horizon

RouterA(config-if)#

From RouterA, watch the routing updates being passed using the debug ip igrp transactions command. Now we see that all routes are being advertised out serial 0, including the routes learned from RouterB on serial 0.

End of Lab