Basic RIP Configuration 

These labs are not as good as the labs in our full blown CCNA Lab Workbook.  The labs in our full blown CCNA lab workbook include theory as we step you through each lab, detailed information on why you are entering each command and review questions and answers at the end of the labs.  So these labs are ok for free…but we offer a much better product consisting of 60 labs covering 400 pages of CCNA material to help you pass your CCNA Certification Exam in the workbook at this link CCNA Lab Workbook!

 

rip

Objective: In this lab, you will configure RIP routes between all three routers. This will allow your routers to route packets so that all routers and all hosts will be able to reach (ping) each other. Once your configuration is complete, you will use basic techniques to test your network’s connectivity.

Hardware Requirements

• One router with two serial ports

• Two routers with one serial port and one Ethernet port

• Two back to back DTE/DCE serial cables

• IOS version 12.x or later

• A PC running a terminal emulation program

• Cisco console kit

 

Setup

• Configure the cabling as shown in the network diagram

• If the routers have a startup-config, erase it and perform a reload of the routers.

 

Router Configurations

RouterA

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname RouterA

RouterA(config)#int loopback0 (Defines a virtual interface that I used as test point)

RouterA(config-if)#ip address 10.1.1.1 255.255.255.0

RouterA(config-if)#no shut

RouterA(config-if)#int e0

RouterA(config-if)#ip address 148.1.1.1 255.255.255.0

RouterA(config-if)#no shut

RouterA(config-if)#

RouterA(config-if)#no keepalive (Disabling the keepalives on the

Ethernet interface, allows the interface to stay up when it is not attached to hub or a switch)

RouterA(config-if)#int s0

RouterA(config-if)#ip address 192.1.1.1 255.255.255.0

RouterA(config-if)#no shut

RouterA(config-if)#

RouterA(config-if)#Router Rip (Enables the RIP routing process on the router)

RouterA(config-router)#network 10.0.0.0 (Specifies what interfaces will receive and send RIP routing updates. It also specifies what networks will be advertised)

RouterA(config-router)#network 148.1.0.0

RouterA(config-router)#network 192.1.1.0

RouterA(config-router)#no ip classless (If there is no specific route for a subnet in the routing table, this command allows the router to forward packets to unknown destinations using the default route. Example….If you use no ip classless, a packet destined for 10.0.0.0 /255.255.0.0 will not be forwarded using the route for network 10.0.0.0 /255.0.0.0)

 

RouterB

Router>en

Router#config t

Router(config)#hostname RouterB

RouterB(config-if)#int e0

RouterB(config-if)#ip address 150.1.1.1 255.255.255.0

RouterB(config-if)#no shut

RouterB(config-if)#no keepalive (Disables the keepalives on the Ethernet interface, allows the interface to stay up when it is not attached to hub or a switch)

RouterB(config-if)#int s0

RouterB(config-if)#ip address 192.1.1.2 255.255.255.0

RouterB(config-if)#no fair-queue (Flow-based weighted fair queuing(WFQ) controls the ratio of transmission bandwidth allocation among different traffic flows during periods of congestion. Class-based WFQ allocates transmission bandwidth among different traffic flows or QoS groups during periods of congestion. WFQ is the default queuing mode on interfaces that run at or below E1 speeds (2.048 Mbps or less). It is enabled by default for physical interfaces that do not use Link Access Procedure, Balanced (LAPB), X.25, or Synchronous Data Link Control (SDLC) encapsulations. WFQ is not an option for these protocols.)

RouterB(config-if)#clockrate 500000 (Acts as DCE providing clock)

RouterB(config-if)#no shut

RouterB(config-if)#int s1

RouterB(config-if)#ip address 193.1.1.1 255.255.255.0

RouterB(config-if)#clockrate 500000

RouterB(config-if)#no shut

RouterB(config-if)#router rip (Enables the RIP routing process on the router)

RouterB(config-router)#network 192.1.1.0 (Specifies what interfaces will receive and send RIP routing updates. It also specifies what networks to be advertised)

RouterB(config-router)#network 193.1.1.0

RouterB(config-router)#no ip classless (If There is no specific route for a subnet in the routing table, this command allows the router to forward packets to unknown destinations using the default route. Example….If you use no ip classless, a packet destined for 10.0.0.0 /255.255.0.0 will not be forwarded using the route for network 10.0.0.0 /255.0.0.0)

 

RouterC

Router>en

Router#config t

Router(config)#hostname RouterC

RouterC(config-if)#int e0

RouterC(config-if)#ip address 152.1.1.1 255.255.255.0

RouterC(config-if)#no shut

RouterC(config-if)#no keepalive (Disables the keepalives on the

Ethernet interface, allows the interface to stay up when it is not attached to hub or a switch)

RouterC(config-if)#int s0

RouterC(config-if)#ip address 193.1.1.2 255.255.255.0

RouterC(config-if)#no shut

RouterC(config-if)#router rip (Enables the RIP routing process on the router)

RouterC(config-router)#network 152.1.0.0 (Specifies what interfaces will receive and send RIP routing updates. It also specifies what networks will be advertised)

RouterC(config-router)#network 193.1.1.0

RouterC(config-router)#no ip classless (If There is no specific route for a subnet in the routing table, this command allows the router to forward packets to unknown destinations using the default route. Example….If you use no ip classless, a packet destined for 10.0.0.0 /255.255.0.0 will not be forwarded using the route for network 10.0.0.0 /255.0.0.0)

 

Monitoring and Troubleshooting the Configuration

RIP is a very simple protocol to configure and troubleshot. Show the IP routing table on

RouterA with the show ip route command.

 

RouterA#show ip route

Find the routing table entries received using the RIP routing protocol.

 

From RouterA, monitor the routing packets being passed using the debug ip rip command.  Notice that on interface serial 0, the router does not advertise the networks it learned from RouterB (152.1.1.0 and 193.1.1.0) but on all other interfaces, those networks are advertised. This is split horizons at work – remember that when split horizons is enabled, the router will never advertise a route back through the interface from which it was learned.

 

RouterA#debug ip rip

RIP protocol debugging is on

FYI:

Split –Horizon – A routing technique used by distance vector routing protocols (RIP, IGRP) to reduce routing traffic on the network. With split-horizon, information about routes is not propagated back into the same interface from which it was learned.

Poison reverse – A route is “poisoned” when a router marks a route as unreachable by setting the hop count to 16 and then passes this route out to a neighboring router, causing the neighboring router to remove the route from its routing table. This speeds network convergence by preventing invalid routes from being propagated throughout the network.

 

These features allow RIP to adjust to network-topology changes and prevent routing loops from being propagated and continuing indefinitely.

 

Now disable split horizons on RouterA using the interface configuration command,

no ip splithorizon.

 

RouterA(config)#int s0

RouterA(config-if)#no ip split-horizon

 

From RouterA, monitor the routing updates being passed using the debug ip rip command.  Notice that now all routes are being advertised out Serial 0, including the routes learned from RouterB on Serial 0.

 

Remember that RIP is a very easy routing protocol to use and troubleshot. It uses hop count as it’s metric and has a maximum hop count of 15 and the destination is considered unreachable at 16.  RIP manages this by changing the administrative distance of hop 16 to 255 which is considered unreachable. Also remember that RIP is a classfull routing protocol and therefore does not include the subnet mask in the routing update. RIP assumes that everyone is using the same subnet mask. One of the primary reasons this came about was because RIP was developed before the need for subnetting came to be.

 

Save your current configurations to NVRAM.

 

End of Lab

RIP (Routing Information Protocol) Review

Questions:

  1. RIP uses hop count as its only metric, in which it can support up to ____ as a maximum.
  2. RIP is a __________________ routing protocol.
  3. RIP’s invalid timer is for ___________ seconds.
  4. RIPv1 broadcasts its routing table every _________ seconds.
  5. RIPv1 considers a neighbor or a network to be dead after _____ missed updates.
  6. _____________________ can support VLSM and discontiguous network designs.
  7. In the chart below, fill in the characteristics for RIPv1 and RIPv2.

Characteristic

RIPv1

RIPv2

Classful/classless

 

 

Algorithm

 

 

Metric

 

 

Maximum hop count

 

 

Infinite metric

 

 

Update/invalid

 

 

Updates

 

 

Load balancing

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8. Which two commands enable a distance vector routing protocol to be classless?

__________________________________________________________________

Answers:

  1. 15
  2. classful
  3. 180
  4. 30
  5. 6
  6. RIPv2

Characteristic

RIPv1

RIPv2

Classful/classless

Classful

Both

Algorithm

Bellman-Ford

Bellman-Ford

Metric

Hops

Hops

Maximum hop count

15

15

Infinite metric

16

16

Update/invalid

30/180

30/180

Updates

Broadcast

Multicast (224.0.0.9)

Load balancing

Equal paths

Equal paths

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8. The only distance vector routing protocol that can be classless is RIPv2.  The command to enable RIPv2 is version 2.  To make it classless, you use the ‘no auto-summary’ command.